Here is a list of all the downloads available.

Dark Age

Your graphics card should support DX9.0c (Shader Model 3.0) to run Dark Age.The latest version comes with an installer that will install the dependencies on your computer. Run the setup.exe that comes with the download.

Note : The latest stable version is the first one on the list.Test Build is for testing out new features.

Downloads:

Koverdo

Downloads:
Want to contact us ?

You got something to share or just want to give some feedback?

Just send an email to barisusakli at gmail dot com and we will get in touch in no time.